Support Center

Name is required.
Email address is required.
Invalid email address
Answer is required.
Exceeding max length of 5KB

Our Fastvue server harddisk is full. I reduced the log size in settings but the disk is still full.

Abigaille Aug 22, 2013 04:32PM PDT

I reduced the size in settings by about 20 GB but the current log size has not changed. Will it delete old logs automatically? OR is there a way to reduce the current log size now?

Up 4 rated Down
Fastvue Aug 22, 2013 10:52PM PDT FASTVUE Agent
Hey Abigaille,

Thanks for getting in touch about this and sorry to hear about the disk space issue.

If you have set the Data Retention policy in Settings | Data Storage, TMG Reporter should automatically reduce your data storage size by purging the oldest data every 5 minutes.

If this is not happening, here are some troubleshooting steps to try:

Log into your TMG Reporter server and navigate to the Data Location (shown in Settings | Data Storage).

Right-click the folder size of the Data.fvfs folder and check the size. Does the size reflect what is specified in your data retention policy in Settings | Data Storage?

If not, check the 'Fastvue TMG Reporter' service is running. It could be that your disk is so full, that the service cannot run at all, and therefore cannot get to the point of purging data. If this is the case, clear enough space for the service to run again by deleting the following files and folders (the service needs to be stopped to do this):

* Dashboard.log
This is just a diagnostic log and does not hold anything vital. Delete it. To ensure it does not grow too large, go to Settings | Diagnostic and ensure the logging level is set to Normal.

* Temp
Before deleting the Temp folder, check its size. If it is large (over 2 GB) then it could be that your machine is under resourced for the amount of log data coming in from your TMG server(s). Try increasing the number of CPUs for a more permanent solution. See: for more information.

* Data.fvfs\...
Drill into the Data.fvfs folder and delete a couple of the oldest .records files. This is the actual data storage that TMG Reporter uses, so any dates you delete (notice the date in each .records filename) will no longer be reported on. If you can avoid deleting files from the Data.fvfs folder by clearing space with other files and folders on your machine, then this is much preferred. Only delete .records files from the Data.fvfs folder if you absolutely have too.

Once you have cleared enough space to run the service again, go to Services and start the Fastvue TMG Reporter service. Monitor the size of the Data.fvfs folder. It should be reduced down to the data retention policy limit within 5 minutes of the service running.

It is important to note that the data retention policy in Settings | Data Storage only applies to the Fastvue TMG Reporter database (the Data.fvfs folder). Other files and folders such as the Dashboard.log, the Temp folder and even the Reports folder are not controlled by the data retention policy.

Therefore, make sure your retention policy leaves enough space on your machine to account for these files and folders.

I hope this helps. Please let us know how you go!

Up -1 rated Down
Abigaille Aug 23, 2013 07:41PM PDT
Deleting the dashboard.log fixed the problem it was 15GB. Thanks!
Up -5 rated Down
Fastvue Aug 23, 2013 07:42PM PDT FASTVUE Agent
Hey! Thanks for letting us know. Glad to hear it's up and running again!


Post Your Public Answer

Your name (required)
Your email address (required)
Answer (required)
seconds ago
a minute ago
minutes ago
an hour ago
hours ago
a day ago
days ago
Invalid characters found